Turning Your Macintosh
into an Electronic
Picture Frame

Most people display pictures on their desk
inside picture frames or hung on the wall as
posters. The problem is that an ordinary pic-
ture frame or poster can get boring after a
while—it always shows the same picture until
you replace it with another one.

Rather than force yourself to deal with such archaic display technology, you
can store and display pictures on your Macintosh screen. By turning your Macin-
tosh into an electronic picture frame, you can display the same image or multiple
images one after another in a slideshow. If you don’t yet have any pictures you
want to display, you can take pictures of yourself or others using your Macintosh
computer’s built-in iSight digital camera.

Project goal: Turn your Macintosh into an electronic picture frame that dis-
plays pictures in a slideshow on your screen.

What You'll Be Using

To turn your Macintosh into an electronic picture frame, you'll need to use the
following items:

> The Finder

> The System Preferences window

> One or more digital photographs

> (Optional) The built-in iSight digital camera
> (Optional) The Photo Booth program
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Creating a Slideshow Folder

Before you can turn your Macintosh into an electronic picture frame, you must first
collect all the pictures you want to display. Normally, you should store all pictures
in the Pictures folder. However, the more pictures you place in the Pictures folder,
the more difficult it can be to find the pictures you want. To solve this problem,
you can create a new folder that stores only those pictures you want to display
(and not those embarrassing pictures of you that you don’t want other people to
see). You can store this folder in the Pictures folder or anywhere else that you find
convenient.

To create a slideshow folder for customizing your screensaver or Desktop,
follow these steps:

1. Click the Finder icon on the Dock. The Finder window appears (if it doesn’t
appear, select File » New Finder Window).

2. Click the Pictures folder in the left pane of the Finder window. The Finder
window displays the contents of the Pictures folder.

3. Select File » New Folder. An untitled folder icon appears in the Finder

window.
4. Type a descriptive name for your folder, such as My Slideshow.
5. Your new folder appears, ready to store any digital photographs you want to

display on your Macintosh.

Storing Pictures in Your Slideshow Folder

Once you've created a slideshow folder, you can start storing your pictures in

it. Any pictures stored in this folder will appear in your slideshow. If you want to
display existing pictures, just copy them into this folder. If you don't yet have any
pictures, you can take pictures using the iSight camera and store them in the

folder.

Copying Existing Pictures into Your Slideshow Folder
To display existing digital photographs, first copy them into your slideshow folder:

1. Click the Finder icon on the Dock. The Finder window appears.

2. Click the storage device that contains the pictures you want to use. (If your
pictures are stored on a compact flash card or flash drive, click the icon that
represents that storage device.)

3. Open the folder that contains the pictures you want to use.

4. Hold down the 3 key and click each picture you want to use. (If you want to
select all the pictures in that folder, press 3-A.)

5. Select Edit » Copy. (Depending on the exact number of pictures you cop-
ied, the command will read Copy X Items.) This copies your selected pictures
(although nothing seems to happen).

6. Click the Pictures folder in the left pane of the Finder window and double-
click your slideshow folder.
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7. Select Edit » Paste Items. Your chosen pictures appear inside the slideshow
folder. (Repeat these steps for any additional pictures you want to use in
your slideshow.)

Copying Existing Pictures from iPhoto into Your Slideshow
Folder

If you have existing digital photographs stored in iPhoto, you can copy pictures
and store them into your slideshow folder:

1. Click the iPhoto icon on the Dock. The iPhoto window appears. (If you
can't find the iPhoto icon on the Dock, look for the iPhoto icon inside the
Applications folder in the Finder window.)

2. Hold down the 3 key and click the pictures you want to store in your slide-
show folder.

3. Select File » Export. An Export Photos dialog appears.

4. Choose any options (such as defining the size of the images) and click
Export. A second Export Photos dialog appears.

5. Click your slideshow folder and click OK.

Capturing Pictures with iSight and Photo
Booth

Most new Macintosh computers include an iSight digital camera that’s built into
the top of the computer screen, like a cyclops’ eye, watching your every move. To
take pictures with iSight, you can use the Photo Booth program.

The Photo Booth program icon looks a lot like the curtain you would close
in a coin-operated photo booth, and that's the idea. No quarters are required for
these photos, though—you've already spent many hundreds of quarters to buy
your Mac. You can take pictures with Photo Booth and store these images in your
slideshow folder:

1. Click the Photo Booth icon on the Dock. (If you can't find the Photo Booth
icon on the Dock, look for the icon in the Applications folder in the Finder
window.) The Photo Booth window appears, as shown in Figure 29-1—and
look, there you are, staring back at yourself. (Better fix your hair first.)

2. Click the Capture button. Photo Booth displays a countdown (3, 2, 1) before
capturing your picture, which then appears at the bottom of the Photo Booth
window. (If you hold down the opTioN key while clicking the Capture button,
Photo Booth will take your picture immediately without the countdown.)

3. Capture as many pictures as you want. Make strange faces, angle or
raise your Macintosh to take pictures of other people across the room, or
hold your dog up to the camera lens and take his picture. This is the time
to let your creativity go wild without losing inhibitions completely, even if it
could mean doing something you might be embarrassed about later.
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FIGURE 29-1: The Photo Booth program immediately
shows the image from the iSight camera lens.

Select Photo Booth » Quit Photo Booth.

Click the Finder icon on the Dock. The Finder window appears.

Click Pictures in the left pane of the Finder window. The contents of the
Pictures folder appears.

Double-click the Photo Booth folder. All the pictures you captured with
Photo Booth appear.

Hold down the 3 key and click each picture you want to use in your slide-
show. (If you want to select all the pictures in that folder, press 3-A.)

Select Edit » Copy X Images. This copies your selected pictures (although
nothing seems to happen).

Click Pictures in the left pane of the Finder window and double-click your
slideshow folder.

Select Edit » Paste Items. Your chosen pictures appear inside the slideshow
folder.
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Creating a Slideshow

After you've stored pictures in your slideshow folder, you can decide how to dis-
play your pictures: on the Desktop or as a screensaver.

Displaying pictures on the Desktop means your images will always appear on
the Desktop screen. Displaying pictures as a screensaver means your pictures will
be displayed only when you stop using your computer and your screensaver starts.
If you want to be able to look at your pictures at any time, display them on the
Desktop. If you want others to look at your pictures while you're away from your
computer, display them as a screensaver.

You can get really creative and have a slideshow appear on both your Desk-
top and screensaver. You can even display one set of pictures as a slideshow on
your Desktop and a second set of pictures as a slideshow on your screensaver, so
that way if you walk away from your computer, your screensaver can show pictures
of you making faces to your boss, co-workers, spouse, kids, and anyone else who
wanders by and stares at your computer.

Displaying a Desktop Slideshow

When you create a slideshow on your Desktop, you must specify how often you
want your pictures to change and how you want them to appear on the screen.

Pictures can change as often as every five seconds or as infrequently as
every day. You can also choose to change pictures only when you log in to your
account (so a different picture greets you every morning) or when your computer
wakes up from going to sleep (so a different picture greets you every time you
return to your computer).

In addition to defining how often your Desktop will display different pictures,
you can also define how your pictures appear. You have five choices:

> Fit to Screen or Fill Screen Both choices enlarge pictures to fill the entire
screen, but small pictures may appear grainy.

> Stretch to Fill Screen This option distorts pictures to fill the entire screen,
which can warp small pictures.

> Center This displays each picture in the middle of the screen at its original
size.

> Tile This choice fills the entire screen with multiple copies of the same
picture.

To create a Desktop slideshow, follow these steps:

1. Click the Apple menu and select System Preferences. The System
Preferences window appears.
2. Click the Desktop & Screen Saver icon under the Personal category.
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3. Click the Desktop tab. The Desktop & Screen Saver window appears, as
shown in Figure 29-2.
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FIGURE 29-2: The Desktop & Screen Saver window allows
you to define which pictures to display and how to display
them.

4. If you can't see the slideshow folder that you created inside the Pictures
folder, click the plus button just below the left pane of the Desktop & Screen
Saver window. The Finder window appears, as shown in Figure 29-3.

5. Click Pictures in the left pane of the Finder window. The contents of the
Pictures folder appears in the right pane.

6. Click your slideshow folder and click the Choose button. The Desktop &
Screen Saver window displays thumbnail images of your pictures, as shown
in Figure 29-4.
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FIGURE 29-3: The Finder window appears so you can choose
your slideshow folder.
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FIGURE 29-4: Thumbnail images of your pictures appear
when you choose your slideshow folder of images.
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Click the picture display pop-up menu, which appears just under the
Desktop and Screen Saver tabs, and choose an option: Fit to Screen, Fill
Screen, Stretch to Fill Screen, Center, or Tile, as shown in Figure 29-5.
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FIGURE 29-5: The picture display list box lets you choose
how to display your pictures.

Check the Change picture checkbox. (If a checkmark already appears, skip
this step.)

Click the Change picture pop-up menu and choose a time duration, as
shown in Figure 29-6.

(Optional) Check the Random order checkbox so your Macintosh displays
pictures in a different order each time instead of alphabetically by filename.
From the Apple menu, select System Preferences » Quit System
Preferences. One of your pictures will appear on the Desktop and will
change based on the time interval you chose.

MY NEW MAC
(C) 2008 by Wallace Wang



[ Deskton| Screen Saver |

p | Screen Saver

¥ Apple
G’ Apple Images
k; Nature

=

Plants

Black & White
| Abstract
') Solid Colors.
[,:1 Pictures Folder
b iPhoto Albums

¥ Folders

[~ My Slideshow

+ |-

e A
o

when logging in
when waking from sleep

every 5 seconds
aevery minute
every 5 minutes
every 15 minutes

Echange pictu

every hour

"1 Random ordert
r every day

FIGURE 29-6: The Change picture pop-up menu lets you
define how often a new picture appears.

Displaying a Screensaver Slideshow

One problem with creating a slideshow directly on your Desktop is that the chang-
ing pictures can be distracting. As an alternative, you might want to create a
slideshow as a screensaver; that way, your slideshow won't begin until you stop
using your computer for a while.

When creating a slideshow as a screensaver, you can define how long your
computer waits before the screensaver starts and in what style you want to display
your pictures. You can use three different types of display styles:

> Slideshow Displays pictures one at a time

> Collage Displays multiple pictures on the screen, mimicking dropping a
picture on a tabletop one at a time

> Mosaic Displays pictures as multiple thumbnail images that fill the screen
in patterns

Turning Your Macintosh into an Electronic Picture Frame
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To create a Desktop slideshow, follow these steps:

Click the Apple menu and select System Preferences. The System
Preferences window appears.

Click the Desktop & Screen Saver icon under the Personal category.
Click the Screen Saver tab. The Desktop & Screen Saver window appears,
as shown in Figure 29-7.
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FIGURE 29-7: The Desktop & Screen Saver window allows
you to define a time for the screensaver to start and a style
in which to display your slideshow.

Scroll down in the Screen Savers pane and click Choose Folder. A new
Finder window appears.

Click the Pictures Folder in the left pane of the Finder window. The con-
tents of the Pictures Folder appears in the right pane.

Click the slideshow folder you created in the Pictures Folder and click
Choose. The Desktop & Screen Saver window displays one of the pictures
in the chosen folder.

Click the Sideshow, Collage, or Mosaic icon in the Display Style group,

as shown in Figure 29-8. The Preview window shows how your slideshow

will look.

(Optional) Click Options. A dialog appears, offering additional ways to mod-
ify the appearance of pictures depending on which display style you chose.
(Optional) Click Test. Your screensaver fills up the screen so you can preview
it. Click the mouse when you're done testing your screensaver.
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FIGURE 29-8: The Desktop & Screen Saver window lets you
preview the images of your slideshow.

10. Drag the Start screen saver slider to specify how much time to wait before
starting the screensaver.

1. From the Apple menu, select System Preferences » Quit System
Preferences.

More Ideas for Displaying Slideshows

Most people are likely to store pictures of different images, such as the family dog
or their spouse and children, and be happy with that. If this sounds too tame for
you, you can get more creative and try some of the following ideas.

Gather some pictures of other people and store those pictures as your
screensaver. That way, whenever you walk away from your desk and your Macin-
tosh’s screensaver kicks in, your boss, co-workers, spouse, roommate, or kids can
watch themselves flashing across the screen. (Just make sure those pictures aren't
embarrassing, or you could find yourself being blackmailed by the people in them,
instead!)

Take some pictures of yourself, and then surprise a friend or relative by
displaying those pictures on his or her Macintosh, either on the Desktop or as a
screensaver. The next time that person uses his or her Macintosh, they’ll see you
staring or waving right back at them.

Instead of storing ordinary digital pictures in your slideshow folder, put
together your own pictures of useful information using a digital editing program
such as the free Seashore program (http://seashore.sourceforge.net/).
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If you're studying a foreign language, gather pictures of different items and
type the English word and its equivalent foreign word for each picture. When your
Macintosh starts running the slideshow, you can use these digital flash cards to
help you study and review.

The same principle can be used for work as well. You can create graphical
images of tasks you need to complete that day or goals you want to achieve. When
your slideshow starts, your Macintosh can remind you of your to-do list or help you
review your goals so you'll remember them and stay focused and motivated.

By turning your slideshow into more than just a picture frame, you can use
your Macintosh as a learning tool, limited only by your own imagination and sense
of humor.
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